wdcp_v3.2正式版发布了
发布时间:2017-09-09 17:35:17 | 作者:kavetr | 分类:网络建设 | 浏览量:931

经过近两周多时间的内测,wdcp_v3.2正式版本,终于可以和大家见面了
在此,感谢那些参与内测的小伙伴们,有你们的参与,wdcp必将更加完美
v3.2版本,最大的亮点,自然是大家期待以久的两大功能
多版本PHP共存和SSL功能设置的支持,现已可以完美的支持
虽有点迟来,但好东西,不怕晚
其实还有一个大亮点,那就是同时支持N+A的组合
也就是说,wdcp的v3.2版本
可以同时支持N+A的组合,以及多版本PHP的共存
同时优化了部分内核代码,操作流程,界面等
功能更强大,使用更灵活,简洁
一如既往的免费
wdCP是什么?关于wdCP更多的介绍,可看
http://www.wdlinux.cn/wdcp/

安装前先去体验下,看演示站
http://www.wdlinux.cn/bbs/thread-52856-1-1.html

安装方法(请使用纯净系统,即不带任何其它WEB环境的系统)
1 只安装wdcp面板看看
wget http://down.wdlinux.cn/in/install_v3.sh
sh install_v3.sh

2 和lanmp环境一起安装
yum install -y wget
wget http://dl.wdlinux.cn/files/lanmp_v3.2.tar.gz
tar zxvf lanmp_v3.2.tar.gz
sh lanmp.sh

可选安装LNMP,LAMP,LNAMP,4全部安装(可切换)
默认安装软件版本为:
nginx-1.8.1
apache-2.2.31
mysql-5.5.54
php-5.5.38
memcache
redis
zend
如需要自定义软件版本,后加cus,如下
sh lanmp.sh cus

如需PHP多版本共存指定使用功能,也需安装,如
sh lib/phps.sh
(共支持7个版本的PHP,如5.2.17/5.3.29/5.4.45/5.5.38/5.6.30/7.0.18/7.1.4)
也可指定安装某一版本,如sh lib/phps.sh 5.2.17
多版本的zend,redis,memcache,opcache.sh扩展支持安装
sh lib/phps_zend.sh
sh lib/phps_redis.sh
sh lib/phps_memcache.sh
默认安装全部PHP版本,也可指定安装某PHP版本,同上

软件安装目录
/www/wdlinux
数据库文件目录
/www/wdlinux/mysql/data

支持组件
zend,memcache,rewrite,pdo_mysql,mysqli等常用组件

支持系统
wdcp_v3 支持wdOS/CentOS5.x/6.x/7.x

3 升级
(3.0/3.1的升级)
可后台直接升级
或使用如下手动升级
wget http://down.wdlinux.cn/in/update_v3.sh
sh update_v3.sh
备注:
此升级只是升级wdcp的后台面板及功能
对于WEB环境的软件需另外升级(无特别需求,WEB环境可不升级或根据需求有针对性的升级)
(2.X的升级)
可用安装方法1中所说方法
关于从v2的升级
对于使用v2的用户
可以单独升级wdcp后台到v3的版本(只安装v3的后台系统就可以,千万不要全新安装,否则很麻烦)
v2/v3升级到v3.2的单独安装多PHP的方法
http://www.wdlinux.cn/bbs/thread-57646-1-1.html

卸载方法
rm -fr /www/wdlinux
reboot

wdcp后台的启动,重起,关闭方法
service wdcp start
service wdcp restart
service wdcp stop

多版本PHP的手动启动|停止|重起
如:5.5
/www/wdlinux/phps/55/bin/php-fpm start
/www/wdlinux/phps/55/bin/php-fpm stop
/www/wdlinux/phps/55/bin/php-fpm restart
如是其它版本,把55替换为相应版本即可

立即咨询